Labels

Monday, December 28, 2009

Advanced UNIX

Linux:
* Create User: adduser plolla -d /home/plolla -s /bin/bash
* Set Password: passwd plolla
* Checking RAM: free -m
* uname -m (The output will read x86_64 for 64-bit and i686 or similar for 32-bit)

Solaris:
* Checking RAM: prtconf | head -3 |grep Mem
* /usr/bin/isainfo -kv (If your OS is 64-bit, you will see output like:64-bit sparcv9 kernel modules. If your OS is 32-bit, you will get this output: 32-bit sparc kernel modules)
* pkgchk -p | grep Package Name
* pkginfo -i system
* pvs -d - Displays the dynamic version of the file.

AIX:
* Checking RAM: $ lsattr -El sys0 | grep realmem
* prtconf
* bootinfo -y ----> hardware is 64-bit or 32
* bootinfo -K ----> kernel is 64-bit or 32 ( to check 64 kernel is installed go to /usr/lib/boot and look for " unix_64 "

Windows :
set p | findstr /i archi
1) PROCESSOR_ARCHITECTURE=x86 ..... 32-bit
2) PROCESSOR_ARCHITECTURE=AMD64 ... 64-bit

HPUX:
to find what OS : getconf KERNEL_BITS
what varsion can run :getconf HW_CPU_SUPP_BITS
$ file /stand/vmunix
/stand/vmunix: PA-RISC1.1 executable ---> 32-bit
/stand/vmunix: ELF-64 executable object file ---> 64-bit
To check the Kernel Variables: kctune or kmtune

No comments:

Learn German - Quick Reference